Generated thumbnails are not scaled properly

For an image that looks like this on disk:

The thumbnail that stagsi generates is this:

I have this problem with all my imported images :frowning: I used the link to the originals import option.

Hey brambleshadow4, it’s great to see you!

As far as I can see, the thumbnail isn’t scaled down to cover the box. This is strange, I haven’t seen this in my tests. Can you attach any one of the original images that show this behaviour?

This is how it looks on my side:

Here’s the original. Hopefully it doesn’t get altered by the uploading process. (SHA256 - B76492F7E0224758E5D8FA661C09A10D4F245676548B28789625E083F12456F0)

I don’t think the bug would be caused by this particular image since I’m seeing it for all images.

Yeah, the image got changed by uploading. I have the same issue with this copy as well.
SHA 256: 14FBCADDFBBBEEC77BDE848940DC3DFAE1ED96D89839F23A2B2EBF29453608CD

I’ve imported the image shared by brambleshadow4 and for me the thumbnail is the same result as Norkov.

I can’t reproduce the the ‘SHA 256’ error, doesn’t happen to me.

P.S. You can maybe try this solution, brambleshadow4. Select a file in the Stagsi browser, press F3 to open the thumbnail settings and click ‘reset thumbnail to original’. Does it fix the bad scaling?

Just put your image in a zip and upload the archive. The forum recompresses graphics to optimize their size.

@brambleshadow4 means that the image file uploaded to the forum is different from the image file on disk so we are not getting exactly the same graphics as he does.

I got this image file (same hash) and it works properly for me as well. Please try this, in order of likely fixes:

1. Try importing this image on another PC

2. Set custom thumbnail

Try pressing F3 in Stagsi’s Object Browser to call Edit Thumbnail and pick any image you want. Then click OK - does it look different/better now?

3. Resize

  • Does it persist if you resize the window?
  • What if you change thumb size (zoom in/out buttons)? image

4. Upload your log file

It would help if you can upload the log file: open Stagsi, import any image that looks bad, go to the menu (see the screenshot) and zip the selected log file in Windows Explorer.

5. Use another plugin

Close Stagsi using File > Exit menu command, go to its folder in Program Files, go to Plugins, remove all DLL files there (making the folder empty) and put these two DLLs instead:
. (10.9 MB)

Then run Stagsi and try importing a new image.

Warning: after extracting the archive go to each of the two DLL’s Properties in Explorer and make sure that there is no Unlock button (or checkbox in Windows 10). If it’s present then click/tick it and click OK:


@brambleshadow4 Hey, any luck?

Sorry for not getting back more quickly.

  1. No can do; I have only one PC.
  2. Edit Thumbnail only lets me upload a jpg. Pretty annoying if all your files are .PNGs. Tried it with the copy from clipboard functionality and it’s still clipped, but it goes away when I use the resize buttons afterwards
  3. Resize buttons alone do nothing. When combined with (2), the problem goes away.
  4. Here’s the logsstagsi (21.3 KB)
  5. No luck with swapping out the libraries.

I second that, nice observation. The program should convert the imported custom thumbnail to the necessary image type. I’m also often confronted to import a custom thumb ‘from file’ that is in .jpg format when Stagsi expects .png. My workaround is to open the .jpg file in photoshop, then select it in order to copy it in clipboard, then import ‘from clipboard’ in Stagsi.

Edit Thumbnail expects you to pick an image in the same format as configured in Stagsi:

So if you are using JPEG thumbs then it expects JPEG. Since you seem to import not photos but computer graphics, I’d suggest switching to PNG to have sharper thumbs.

I admit it’s a sensible request. The reason why it isn’t implemented this way is because currently Stagsi simply copies the picked file directly to the database without performing image convertion. It involves more work if done as you described, but it also allows interesting features such as allowing to set thumb in any format recognized by Stagsi (like SVG).

I will take a note on this.

This is really, really strange.

The logs are just fine. I have no idea how it can happen - do you mind if at some point we connect using TeamViewer so I can poke around and see it for myself?

Update: now that I think about it, try changing thumbnail format from JPEG to PNG. Stagsi will ask you to regenerate them - do that (it will take a minute or so for <200 objects). Perhaps it will change something.

I think I could reproduce the glitch on my side. It may be related to the glitch described by brambleshadow4. See this video:

For me it seems to occur when zoom is maximum and in ‘List View’ mode. The image is simply not fitting inside the canvas, it’s cropped instead. But in ‘Grid View’ mode, this issue isn’t occurring.

It’s hard to tell if that’s what brambleshadow experienced exactly but that’s a good clue.

wondering if there’s any way to circumvent this years-old issue, i’ve tried everything mentioned in this thread and it still doesn’t want to cooperate. i’d love to use stagsi but it’s impossible to tag thousands of images in bulk with how little of each image i can see. here’s my test image, and how it shows in the UI:
278207b292433a1df9c19f12f080c327.jpg (300×300) (

Have been super happy to move over to my new build and begin a library/ data archive using Stagsi. Unfortunately I’m also running into severe thumbnail issues. I’ve tried the plug-ins fix mentioned earlier in this thread and I’m not having any luck. When I sort with crisper/ PNG friendly images, literally no thumbnails generate at all. With the JPG option, each image is horribly cropped with no fix in sight.

Also, this might be a n00b question, but I’m configuring which programs open what types of files and the .exe for windows photo viewer is literally nowhere to be found in my root files. I literally cannot figure out how to create a shortcut or open the application from anything other than my taskbar or naturally through windows default settings (windows 11). I’m not exactly tech illiterate, so either I’m missing something, or this is as needlessly frustrating as I think it is…
Short fix is I’ll just use another 3rd party application of whatever, probably VLC, but any help is appreciated.

Please respond, I really want to create a huge archive/ database to make the flow of content creation/ video editing as good as it could be, without the hassle of sorting through hierarchal data structures. Thank you!

I’ll even put a $30 bounty on anyone who can solve the problem. Thanks!


First of all, let me say that Stagsi development is currently on hold. I do however have some info regarding this problem: it often happens on monitors configured with non-100% DPI (scaling factor). Right-click on an empty space on your desktop and call up Display settings to check it:


I haven’t confirmed this but if the problem lies within thumbnail generation then you may be able to set scaling to 100%, close Stagsi and run Stagsi.exe /rethumb to fix them, then revert to your scaling of choice. However, if the issue is with how Stagsi displays the thumbnails (as I suspect it is), then you might not be able to use the current version with custom scaling at all.

I will look for a solution and keep you posted if I find anything useful.

I personally suggest FastStone Image Viewer which is free and very robust.

I believe you mean the newer Windows Photos app that replaced WPV after Windows 7. The problem with Photos is that it’s a Metro app, not something that you install into Program Files with a runnable EXE. You can create a shortcut/launch such an app but I don’t know of a method to make it open a particular file.

However, there is a workaround: if Photos is set as the default viewer in Windows then go to Stagsi’s Settings → Internal File Associations, click on Edit next to the image type you want opened with Photos, click Add program and select (or enter) C:\Windows\explorer.exe. Then you’ll have a list like this:


Now opening a file with “Windows Explorer” will actually open it with the default program associated to that file type (which can be any Metro app). Further, if you want to avoid Stagsi prompting you with this dialog every time you open an image, set Action to Call first configured and make sure to drag the “Windows Explorer” entry to the first place.

One thing I forgot to mention is overriding scaling method Windows uses for Stagsi in particular. Stagsi’s interface will look blurry but I have confirmed thumbnails to work properly once this is done so this is better than nothing.

Find where your Stagsi.exe resides, open its Properties, switch to Compatibility, click on Change high DPI settings, tick Override high DPI scaling behavior and change Application (the default) to System or System (Enchanced):

After that close Stagsi and run Stagsi.exe /rethumb.

Hey thank you so much :slight_smile: This fixed everything for me.
Drop an ETH address or DM me a venmo if you want your bounty… it’s not much, but I appreciate your help with this issue!

Good news, the problem with the thumbnails and large DPI has been fixed in code so there’s no more need for high DPI scaling behavior override.

We have released two new versions: 1797 with this fix and the fix for EXIF rotation flag (that’s not being accounted for) and 1802 with a few minor new features (video thumbnail plugin (but it can work on 1797 too), bypassing NoThumbThreshold limit meaning all files now get thumbnails regardless of their size, plugin-dictated sort order, and others).

The files are here. To update, either install on top of your existing installation or extract dist from 7z/zip archive onto it (be sure to delete Bootstrap.json if not using portable mode).

Sadly, we currently lack the ability to thoroughly test new features. In particular, /hidden and plugin sorting seem to cause issues; if that’s the case for you, use 1797 - it should be more stable.

Thanks, we wouldn’t say no to that. Sent you a DM.