ISSUE: Generated thumbnails are not scaled properly

For an image that looks like this on disk:
image

The thumbnail that stagsi generates is this:
image

I have this problem with all my imported images :frowning: I used the link to the originals import option.

Hey brambleshadow4, it’s great to see you!

As far as I can see, the thumbnail isn’t scaled down to cover the box. This is strange, I haven’t seen this in my tests. Can you attach any one of the original images that show this behaviour?

This is how it looks on my side:
image

Here’s the original. Hopefully it doesn’t get altered by the uploading process. (SHA256 - B76492F7E0224758E5D8FA661C09A10D4F245676548B28789625E083F12456F0)
EqD130

I don’t think the bug would be caused by this particular image since I’m seeing it for all images.

Yeah, the image got changed by uploading. I have the same issue with this copy as well.
SHA 256: 14FBCADDFBBBEEC77BDE848940DC3DFAE1ED96D89839F23A2B2EBF29453608CD

I’ve imported the image shared by brambleshadow4 and for me the thumbnail is the same result as Norkov.

I can’t reproduce the the ‘SHA 256’ error, doesn’t happen to me.

P.S. You can maybe try this solution, brambleshadow4. Select a file in the Stagsi browser, press F3 to open the thumbnail settings and click ‘reset thumbnail to original’. Does it fix the bad scaling?

Just put your image in a zip and upload the archive. The forum recompresses graphics to optimize their size.

@brambleshadow4 means that the image file uploaded to the forum is different from the image file on disk so we are not getting exactly the same graphics as he does.

I got this image file (same hash) and it works properly for me as well. Please try this, in order of likely fixes:

1. Try importing this image on another PC

2. Set custom thumbnail

Try pressing F3 in Stagsi’s Object Browser to call Edit Thumbnail and pick any image you want. Then click OK - does it look different/better now?
image
.
image

3. Resize

  • Does it persist if you resize the window?
  • What if you change thumb size (zoom in/out buttons)? image

4. Upload your log file

It would help if you can upload the log file: open Stagsi, import any image that looks bad, go to the menu (see the screenshot) and zip the selected log file in Windows Explorer.
image

5. Use another plugin

Close Stagsi using File > Exit menu command, go to its folder in Program Files, go to Plugins, remove all DLL files there (making the folder empty) and put these two DLLs instead:
.
MagickPlugin.zip (10.9 MB)
.
image

Then run Stagsi and try importing a new image.

Warning: after extracting the archive go to each of the two DLL’s Properties in Explorer and make sure that there is no Unlock button (or checkbox in Windows 10). If it’s present then click/tick it and click OK:

i

@brambleshadow4 Hey, any luck?

Sorry for not getting back more quickly.

  1. No can do; I have only one PC.
  2. Edit Thumbnail only lets me upload a jpg. Pretty annoying if all your files are .PNGs. Tried it with the copy from clipboard functionality and it’s still clipped, but it goes away when I use the resize buttons afterwards
  3. Resize buttons alone do nothing. When combined with (2), the problem goes away.
  4. Here’s the logsstagsi logs.zip (21.3 KB)
  5. No luck with swapping out the libraries.

I second that, nice observation. The program should convert the imported custom thumbnail to the necessary image type. I’m also often confronted to import a custom thumb ‘from file’ that is in .jpg format when Stagsi expects .png. My workaround is to open the .jpg file in photoshop, then select it in order to copy it in clipboard, then import ‘from clipboard’ in Stagsi.

Edit Thumbnail expects you to pick an image in the same format as configured in Stagsi:
image

So if you are using JPEG thumbs then it expects JPEG. Since you seem to import not photos but computer graphics, I’d suggest switching to PNG to have sharper thumbs.

I admit it’s a sensible request. The reason why it isn’t implemented this way is because currently Stagsi simply copies the picked file directly to the database without performing image convertion. It involves more work if done as you described, but it also allows interesting features such as allowing to set thumb in any format recognized by Stagsi (like SVG).

I will take a note on this.

This is really, really strange.

The logs are just fine. I have no idea how it can happen - do you mind if at some point we connect using TeamViewer so I can poke around and see it for myself?

Update: now that I think about it, try changing thumbnail format from JPEG to PNG. Stagsi will ask you to regenerate them - do that (it will take a minute or so for <200 objects). Perhaps it will change something.
image

I think I could reproduce the glitch on my side. It may be related to the glitch described by brambleshadow4. See this video:

For me it seems to occur when zoom is maximum and in ‘List View’ mode. The image is simply not fitting inside the canvas, it’s cropped instead. But in ‘Grid View’ mode, this issue isn’t occurring.

It’s hard to tell if that’s what brambleshadow experienced exactly but that’s a good clue.